Online Sim Racing netKar PRO


    Start and Pit Lights

    Share
    avatar
    Gary Levy
    Driver
    Driver

    Posts : 90
    Join date : 2010-11-14
    Age : 46
    Location : Dorset, England

    Start and Pit Lights

    Post by Gary Levy on Wed Nov 17, 2010 2:14 pm

    Hello All Smile

    Firstly apologies, I'm afraid I don't speak Italian Crying or Very sad
    I've been looking round this forum for some time, checking out the great tracks some of you guys are developing, and also reading the tutorials etc. So I thought I'd try my own conversion of Brands Hatch from rFactor.

    Thanks to the advice on here it's been going pretty well (after starting again from scratch 3 or 4 times Smile ). But what I can't work out is how to properly implement the Start lights and Pit lights.

    I'm sure I read somewhere that I'ts got something to do with detaching the objects by ID? Do the lights have to be not detached?
    I'm totally confused.

    If someone could please point me in the direction of a guide on how to do this or offer me some advice (or even a .max file so I could see for myself Very Happy ) I would be very, very grateful indeed. It would mean hopefully I can get my track finished and uploaded for all. Smile

    Thanks in advance for any replies.

    Gary.
    avatar
    Andrea Lojelo
    ---
    ---

    Posts : 12576
    Join date : 2009-04-26
    Age : 38
    Location : Den Haag

    Re: Start and Pit Lights

    Post by Andrea Lojelo on Wed Nov 17, 2010 2:48 pm

    Hi Gary, don't worry about the language. The official language here is English, with some Italian also... Wink

    Lights in nk works pretty differently from rf. you can find here some infomations about it

    About detaching, the reason is that netKar don't allow to use multimaterial objects, therefore you need to detach them.

    If you are converting from rf, you can delete some objects created for rf like sectors planes, lights planes (i mean the red and and green planes to create the light effect).

    I hope this help.
    I don't have so much experience with track conversion, I just know the basics.
    If you still have problems, please let us know. Someone else can help you out for sure


    _________________
     
    avatar
    Gary Levy
    Driver
    Driver

    Posts : 90
    Join date : 2010-11-14
    Age : 46
    Location : Dorset, England

    Re: Start and Pit Lights

    Post by Gary Levy on Wed Nov 17, 2010 3:42 pm

    Thanks for the quick reply Andrea Smile

    So if I understand it correctly, as long as I've got the actual lense objects (usually little squares) ,named correctly i.e LIGHT_red, LIGHT_green, netkar will understand this and work ok?

    I don't need the glowing red and green textures that export from rFactor?

    It's difficult to test without having a race Smile
    avatar
    Andrea Lojelo
    ---
    ---

    Posts : 12576
    Join date : 2009-04-26
    Age : 38
    Location : Den Haag

    Re: Start and Pit Lights

    Post by Andrea Lojelo on Wed Nov 17, 2010 3:55 pm

    yes, correct. you can delet the glowing red.
    I advise you to use the lights ON textures from some of the nk tracks like aviano, for example.
    Those just need to cover the lights OFF of your starting lights.

    The best way is to check if lights are ON in practice (offline)
    and then create a server and join to see if lights are OFF once you join the server


    _________________
     
    avatar
    Marco Calesella
    Driver
    Driver

    Posts : 220
    Join date : 2010-09-15
    Location : Schio (VI) Italy

    Re: Start and Pit Lights

    Post by Marco Calesella on Wed Nov 17, 2010 6:44 pm

    Are the Pit light supported in netKar?

    As far as I understand no, but can you please confirm me?
    avatar
    Andrea Lojelo
    ---
    ---

    Posts : 12576
    Join date : 2009-04-26
    Age : 38
    Location : Den Haag

    Re: Start and Pit Lights

    Post by Andrea Lojelo on Wed Nov 17, 2010 7:03 pm

    no pit lights. but, as someone suggested would be a nice feature.


    _________________
     
    avatar
    Marco Calesella
    Driver
    Driver

    Posts : 220
    Join date : 2010-09-15
    Location : Schio (VI) Italy

    Re: Start and Pit Lights

    Post by Marco Calesella on Wed Nov 17, 2010 7:15 pm

    Andrea Lojelo wrote:no pit lights. but, as someone suggested would be a nice feature.

    Yes, definitively a nice feature. I asked in the Wish list thread of DI, even if I don't trust a lot that kind of thread! Very Happy

    Better if someone ask from "inside" to kunos! ;-)
    avatar
    Gary Levy
    Driver
    Driver

    Posts : 90
    Join date : 2010-11-14
    Age : 46
    Location : Dorset, England

    Re: Start and Pit Lights

    Post by Gary Levy on Thu Nov 18, 2010 12:22 pm

    Just to say, thanks a lot for the help. Lights are working fine now Very Happy

    René Lorig
    Driver
    Driver

    Posts : 297
    Join date : 2010-04-22
    Age : 23
    Location : Braunschweig, Germany

    Re: Start and Pit Lights

    Post by René Lorig on Mon Dec 20, 2010 10:31 pm

    They aren't working for me, is there anything I have to add to the Lights? Like a second material in front of the normal light, with the starting light on it?
    My problem is, everytime I start a race the lights are just black textures till the point where they should go red, then they have the correct texture.
    Sad
    avatar
    M Carey
    Driver
    Driver

    Posts : 1076
    Join date : 2010-04-20

    Re: Start and Pit Lights

    Post by M Carey on Mon Dec 20, 2010 11:47 pm

    Create additional planes just infront of the lights. Name them and map the correct textures (the green & red lights). They should then work.
    avatar
    Andrea Lojelo
    ---
    ---

    Posts : 12576
    Join date : 2009-04-26
    Age : 38
    Location : Den Haag

    Re: Start and Pit Lights

    Post by Andrea Lojelo on Tue Dec 21, 2010 1:19 am

    this is what we usually use for the lights.
    small planes, with lights ON textures, to position just in front of your lights (OFF).



    _________________
     

    René Lorig
    Driver
    Driver

    Posts : 297
    Join date : 2010-04-22
    Age : 23
    Location : Braunschweig, Germany

    Re: Start and Pit Lights

    Post by René Lorig on Tue Dec 21, 2010 4:45 pm

    Do I have to make them transparent? (the ON textures/planes)
    Because before they go on they look like this in a race: Lights
    In Practice everything is fine and they are on at all times.
    So, Transparent, Shader what have I missed?
    EDIT: Making them transparent, didn't work. Is it correct to have the LIGHT_on textures assigned to the planes as material (in max)?
    avatar
    M Carey
    Driver
    Driver

    Posts : 1076
    Join date : 2010-04-20

    Re: Start and Pit Lights

    Post by M Carey on Tue Dec 21, 2010 5:39 pm

    Are your lights working (if you setup a server on your own you should see the red appear (then the server will reset as they go green))? You might be having the same problem I have at Mountain Sprint, I tried literally everything to try and fix it, but was just left confused as there wasn't a problem with the start lights @ Osch' (or any other track I checked).

    René Lorig
    Driver
    Driver

    Posts : 297
    Join date : 2010-04-22
    Age : 23
    Location : Braunschweig, Germany

    Re: Start and Pit Lights

    Post by René Lorig on Tue Dec 21, 2010 6:59 pm

    Yes they are working in race (but only when they are supposed to) and in practice, but pre-start they are black. (Not totally you can see the green and red lights a little bit).
    Okay, then it's a bit of a surprise when the lights appear at the start of the race. Very Happy
    avatar
    M Carey
    Driver
    Driver

    Posts : 1076
    Join date : 2010-04-20

    Re: Start and Pit Lights

    Post by M Carey on Tue Dec 21, 2010 7:16 pm

    Same problem then, I wish I could help you cos then I'd know Smile

    Sponsored content

    Re: Start and Pit Lights

    Post by Sponsored content


      Current date/time is Tue Oct 17, 2017 12:34 pm